OpenWrt bricks Xiaomi Mi Router 4A (MIR4AC) 100M international version

Hi,

i bricked my mi router 4a (mir4ac) 100mbps international version by flashing;

This Firmware

i can fix my device by flashing factory image. No problem. But what is wrong? which firmware should i use?

See the installation methods on the hardware data page -

The git-commit install instructions -

https://git.openwrt.ifw.cn/?p=openwrt/openwrt.git;a=commit;h=5ff5c9bce6b6e51060c272521528b5afd789e9ab

Hi,
Actually i have mi4a giga edition and already using openwrt.

This mir4ac 100m (global version) device is my friend's device. He asked me to install openwrt to his device. I tried to install with same way but can not boot. it stucks at blinking orange led. I saw some installation guides and realized that same methods. But it fails. What is the problem?
hoddy's guide not worked for me too. @hoddy can you help me?

1 Like

https://hoddysguides.com/xiaomi-debrick-tools-all/amp/ already checked the site?

1 Like

Yes. I flashed stock firmware and it is working. No problem with it.
My problem is flashing openwrt to mir4ac (mi 4a 100m global). After flashing it does not booting.

I can flash firmware to my mi 4a giga with this (hoddy's) guide. I am using mi 4a giga at home. Working great.

Actually I can flash firmware to mir4ac too, it does not give any error. But after first boot it always blinks orange led and only 1-2 times blue led but can not reach luci. No more blue led blinking after 1-2 blinks.

Sorry, misread your 1st post, you clearly stated it.

So it is tagged as "stable". Why it does not booting? what could i be doing wrong? i am flashing same way with mi4a giga.

hard to say without serial console access, try an older image, see if it works, then update your way forward.

Tried with v19 stable release. Not worked.
I think i am doing something wrong.
If it is tagged as stable, someone tried it right?
So there must be something wrong with me.

Maybe this cause my problem?

It is from Dec20. So is there any build for new variant?

What flash chip is in your R4AC?

The EON EN25QX128A has been found in chinese versions of the R4AG and R4C.
https://github.com/openwrt/openwrt/issues/9442

1 Like

Can i check it without opening box? Your link is for gigabit edition i think. i am talking about 100m edition.
i am telling it is global because if i flash chineese factory image it goes bootlop but if i flash global factory image it boots.

Try looking through the ventilation holes in the case. The 8 pin chip closest to the blue WAN socket

https://openwrt.ifw.cn/_media/media/xiaomi/mi-router-4a-100m-serial.jpg?cache=

Hi again. I opened the device. Tried to take photo.

0giga
GigaDevice
25Q127CSIG

Exact same GigaDevice part number fitted to both my R4AG 'Giga' International routers made in 2019.

ie. your problem is not to do with Eon flash chip issue affecting other Xiaomi routers.

You can flash openwrt to this chip?
So what is the problem?
I am doing same way with my mi4a gigabit router. Only changing firmware url in guide.

so not needed to patch partition table?
what is wrong :frowning:

it seems the partition table problem. Did you tried to back stock fw v2.18.28?

flashing chinese stock fw bricks device. i returned international stock fw. now 3.0.5 is installed.

2 suggestions:

  1. connect UART to USB to log out the openwrt when initial, check what real happened.
  2. not use openwrt on your 4A set, get another cheap router for openwrt, likes Xiaomi 4C.

Can you dump the full flash chip to a file when you have the international stock firmware installed on it? If it's a partition table issue, it should be pretty easy to check and make a variant with a modified DTS for it.