OpenWrt 22.03.0-rc4 fourth release candidate

Hi,

The OpenWrt community is proud to announce the fourth release candidate of the upcoming OpenWrt 22.03 stable version series. It incorporates over 3500 commits since branching the previous OpenWrt 21.02 release and has been under development for about one year.

This is just a release candidate and not the final release yet.

Download firmware images directly from our download servers:

OpenWrt 22.03.0-rc2 was skipped because the URL of the release repository was not updated correctly.

OpenWrt 22.03.0-rc3 was skipped because of a severe problem in firewall4.

Changes between OpenWrt 22.03.0-rc1 and 22.03.0-rc4

Software updates

  • Linux kernel updated to version 5.10.120 (from 5.10.111 in v22.03.0-rc1)
  • wolfssl Update to version 5.3.0 (from 5.2.0 in v22.03.0-rc1)
  • openssl Update to version 1.1.1o (from 1.1.1n in v22.03.0-rc1)

Misc changes

  • ucode: many updates
  • firewall4: many updates
  • Multiple fixes for flow offload fixing problems with IPv6 and PPPoE

Device support

  • New devices
    • ath79: TP-Link Deco M4R
    • ath79: Netgear WNDAP360
    • ath79: MikroTik RouterBOARD 952Ui-5ac2nD (hAP ac lite)
    • ath79: MikroTik RouterBOARD 951Ui-2nD (hAP)
    • ath79: Ubiquiti NanoBeam M5
    • bcm53xx: Asus RT-AC88U
    • ipq806x: Arris TR4400 v2
    • ramips: YunCore AX820
    • ramips: TP-Link RE650 v2
    • ramips: Wavlink WL-WN533A8
    • ramips: SERCOMM NA502S
    • ramips: Cudy X6
    • realtek: ZyXEL GS1900-16
    • realtek: ZyXEL GS1900-24E
  • lantiq: Add upstream vectoring support

Many other changes in all parts of OpenWrt, see Chnagelog for details.


Full release notes and upgrade instructions are available at
https://openwrt.ifw.cn/releases/22.03/notes-22.03.0-rc4

In particular, make sure to read the regressions and known issues before upgrading:
https://openwrt.ifw.cn/releases/22.03/notes-22.03.0-rc4#known_issues

For a detailed list of all changes since 22.03-rc1, refer to
https://openwrt.ifw.cn/releases/22.03/changelog-22.03.0-rc4

To download the 22.03.0-rc4 images, navigate to:
https://downloads.openwrt.ifw.cn/releases/22.03.0-rc4/

As always, a big thank you goes to all our active package maintainers, testers, documenters, and supporters.

Have fun!

The OpenWrt Community


To stay informed of new OpenWrt releases and security advisories, there
are new channels available:

21 Likes

Thank you all for yor work, I will test it soon in my zbtlink zbt-we1326 and will report back any issue

Installed in my WAC104 setup as a dumb AP. No issues.

Just sysupgraded a ZyXEL GS1900-24HPv1 from rc3 to rc4 with keeping the config and is still working, even the dualboot to OEM ZyXEL.

2 Likes

I'm running rc2 on an R7800 without any noticeable issues.
If I point to the rc4 package repo, is an "opkg upgrade" assumed to work?

1 Like

No. Likely you would get incompatible kernel packages or missed dependencies.

"opkg upgrade" only upgrades individual packages, but does not touch the kernel or DTS or ...

OpenWrt assumes really limited storage space, so there is no in-place kernel upgrade or related functionality.

You need an actual sysupgrade for getting the rc4.

3 Likes

I've always run the image for NanoStation loco M5 XW (which was ported to ath79 a long time ago) on my NanoBeam M5's. Is there something specific to the NanoBeam in there now?

Thanks devs for all the hard work, it's getting closer :smiley: My WRT32X is on a 200+ day uptime (on 21.02 with a 5.10 kernel upgrade), not quite ready to make the jump yet.

1 Like

WRT1900ACSv2 running OpenWrt 22.03.0-rc4 r19426. Upgraded from rc1 with retained configuration. 5Ghz set to channel 36. WPA2. I continue to have the following:

  • irqbalance enabled (from '0' to '1' in '/etc/config/irqbalance')
  • SQM QoS enabled
  • tx_amsdu disabled. Luci > startup > local startup (nano /etc/rc.local) the following commands:
echo "0" >> /sys/kernel/debug/ieee80211/phy0/mwlwifi/tx_amsdu
echo "0" >> /sys/kernel/debug/ieee80211/phy1/mwlwifi/tx_amsdu

13d uptime.

No observed issues. This is the best OpenWRT build yet. Extremely pleased with my performance.

Hi guys. I have router Mercury MAC1200R v1 but only openwrt v19.07, can help upgrade Mercury MAC1200R v1 to latest openwrt please (sorry my English very bad). Thank you guys.

Software updates

  • Linux kernel updated to version 5.10.120 (from 5.4.111 in v22.03.0-rc1)

did devs changed major kernel version between RCs? that's weird.

That is, obviously, a typo. rc1 was released with 5.10.111 (see relevant commit and release notes)

7 Likes

Thank you all. Just installed on my extender (Netgear EX6150v2) 22.03.0-rc4, upgrading from some snapshot version, configuration retained correctly, will test a little and upgrade the main router tonight..

The MAC1200R v1 has only 8MB flash and 64MB memory (8/64). See 864_warning.

Users that are not expert users of OpenWrt (those that can build their own images) should consider 16/64 as an absolute minimum for any device, with at least 128 MB of RAM being preferred.

Unfortunately, 19.07 appears to be the last stable release supporting this device and 19.07 was also the last stable release to support the ar71xx target. The MAC1200R v1 was not migrated from the ar71xx target to the ath79 target as of the 21.02 stable release.

1 Like

Hi there.
Successfully installed 22.03.0-rc4 on these devices, with various configs (router, mesh, AP)

  • x86-64 miniPC
  • Linksys MR8300 (ipq4019 generic)
  • Netgear R6220 (mt7621)
  • Netgear 3700v2 (ath79 generic). I have several of these as low-end APs. I have tested 22.03.0-rc4 on one, but I will reverse it back to 21.02 because it has a lower memory print.

Thank you to every devs and contributors.

1 Like

I successfully upgraded to 22.03.0-rc4 on these devices:

  • rpi-4-ext4 router which was previously on 22.03.0-rc1 using luci-app-attendedsysupgrade
  • eap615-wall access point which was previously on 22.03.0-rc3 using manual flash of sysupgrade.bin

Many thanks to all who contributed!

Is flow offloading fixed? Like for realsies? Can someone who previously had problems (ipv6 sites like google and facebook simply stop responding in a few minutes + general non-responsiveness) please test and post?

I've been waiting for flow offload to be fixed for over a year now, and want to upgrade only for that.

I use TP-Link AC1750 (Archer A7=C7 v5) in a fairly vanilla (internet->wifi/lan, guest radio) configuration. The only weird thing I have is ddns and vnstat. Those have previously worked seamlessly with sysupgrade (I had problems with the regular firmware upgrade before starting to use sysupgrade like the router stopped responding, and obviously I have to redownload and redo the config for the "non-standard" packages like ddns).

I also have a question - if I upgrade via sysupgrade to rc4, keeping configuration, is it likely to work seamlessly, and then also from rc4 to the release version? I read about problems with configs not working with migration to rc3 (?). I know nothing is ever "guaranteed" because open source, large team, etc. but still - has anyone tried and did it work for rc4?

Thanks

1 Like

re: sysupgrade, it's more important what the delta is between what you're coming from and moving to. If your current setup is pre-DSA, you'll probably want to strongly consider manually setting everything up from scratch versus just a straight config-preservation upgrade. If you're already on RC1, for example, it's a very direct migration to RC4 (and final).

Used the imagebuilder to add all my packages and configs.

From 22.03.0-rc1 to 22.03.0-rc4 on a raspberry pi 4b

|Model|Raspberry Pi 4 Model B Rev 1.2|
|Architecture|ARMv8 Processor rev 3|
|Target Platform|bcm27xx/bcm2711|
|Firmware Version|OpenWrt 22.03.0-rc4 r19426-2b1941e47d / LuCI openwrt-22.03 branch git-22.140.66268-ef99568|
|Kernel Version|5.10.120|

Firewall warning:

mwan3 and vpn policy routing, seems to be still on iptables.

@feckert topic tells me it should work. (It does but complains about the use of iptables)
https://forum.openwrt.ifw.cn/t/mwan3-nftables-porting-help/120895/3