Latest snapshot - still problems with installing packages

Hi!

I have a Raspberry Pi 4 B.

I installed latest snapshot (I suppose) today around 19.00, following this guide: https://www.youtube.com/watch?v=_MFkbcNFIqo

But still, I get mismatch-error when trying to install packages in LuCI. I also tried to install the "package" (is that the name for it?) in "make menusetup", saved, and then "make -j5" - with no luck. It wasnt even in the list when I booted up the RPi4/openwrt and looked in the installed software-menu in LuCI.

Tried to install wireguard and some QoS-software but both of them get this "wrong kernel-error".

Here is a picture: https://www.bildtagg.se/bild/gbb4m85jc999z7au5325kpt

What to do? When can we expect a stable version for RPi4? Anyone that can tell me something about this?

Thanks in advance!

/pjougazohrd

did you use this to download the snapshot?

openwrt-firmware-selector

When you get the message “Cannot satisfy the following dependencies for…” it is most likely because you installed a snapshot version of OpenWrt.
Read here for possible solutions.

Ah, ok. Think I didn't have the latest snapshot after all. I deleted the whole openwrt-folder and started from scratch with "git clone https://github.com/openwrt/openwrt.git", "./scripts/feeds update -a", "./scripts/feeds install -a" and stuff like that :grin:

I tried to upgrade and thought "./scripts/feeds update -a" and "./scripts/feeds install -a" would be enough and after that just do a "make menuconfig" and "make -j5". But seems like I were stuck on old version anyway... I'm a noob :grin:

Followed this guide (instructions is also written in plan text under the video): https://m.youtube.com/watch?v=_MFkbcNFIqo&t=2228s

If you created your own image, you "have to" use your own packages as well.

You're not supposed to UL/boot a self made image, then grab the packages online.

1 Like

Ok. But then I also have to know what all packages name are and hope that they're included.

Is there a way to download a complete "a whole set" of packages for a application I want to be included when I make my install? For example, I want to install wireguard - then I download everything that may be needed. And where do I place my packages before "doing a make" (compile?)?

In fact wireguard were in the "make menuconfig", but think I had to add/install some more "packages" when I searched for wireguard in LuCI after install.

Any ideas how I do to just update to latest version before I want to make a fresh install instead of deleting the whole openwrt-map and start all over again? Think there is a git-command, like "git upgrade" and then check status with "git status". Is that correct?

Well,

You can see the package dependencies for wireguard at https://openwrt.ifw.cn/packages/pkgdata/wireguard

The packages you enable will be compiled, and their dependencies too, if I remember correctly.

If you would like to skip the whole thing, download the premade snapshot, and install the
packages you need.

The next snapshot created will invalidate the current packages, so you either have to install
everything you think you need at once, or make a local backup of the whole package repository.

... or be prepared to redo the whole process again :wink:

If you are not going to modify the packages themselves, just create an image with a specific list of packages, you can use the image builder instead: